[jboss-user] [Datasource Configuration] - Re: Unable to get managed connection for jdbc

titang do-not-reply at jboss.com
Fri Apr 29 11:50:16 EDT 2011

titang [http://community.jboss.org/people/titang] created the discussion

"Re: Unable to get managed connection for jdbc"

To view the discussion, visit: http://community.jboss.org/message/602751#602751

I am still having the same problem. The datasource seems to be well set cause if I put a wrong jndi-name or if I have any error in my jboss-web.xml , the lookup code is not even executed.

I did not mention it but I am using jBoss 6. I tried to deploy my application on jBoss 5 and it worked. I had some execution problems but I was able access the database.

I also tried to use ojdbc5.jar, but it did not improve anything. 

My main issue are in fact those exceptions:

ERROR  /message/org.rhq.core.pc.inventory.InventoryManager org.rhq.core.pc.inventory.InventoryManager Call to getAvailablity() on ResourceComponent for Resource[id=-49, type=Service Binding Manager, key=ServiceBindingManager, name=Service Binding Manager, parent=JBoss AS 6 (default)] failed.: org.rhq.core.pc.inventory.TimeoutException: Call to  /message/org.rhq.plugins.jbossas5.serviceBinding.ManagerComponent.getAvailability() org.rhq.plugins.jbossas5.serviceBinding.ManagerComponent.getAvailability() with args [] timed out. Invocation thread will be interrupted

I have no clue which part of my application is involved in these errors. And I don't know if it is related to the impossibility to get a connection to the datasource. How could I know which resource is raising this exception?

Tanks again.

Reply to this message by going to Community

Start a new discussion in Datasource Configuration at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110429/089a1eb9/attachment.html 

More information about the jboss-user mailing list