[jboss-user] [jBPM] - jbpm5 not able to run multiple instances of a process

ritesh adval do-not-reply at jboss.com
Fri Jan 14 00:50:04 EST 2011

ritesh adval [http://community.jboss.org/people/riteshadval] created the discussion

"jbpm5 not able to run multiple instances of a process"

To view the discussion, visit: http://community.jboss.org/message/580755#580755

I ran the sample tests in jbpm-bpmn2 source directory to test if multiple process instance can be run where each instance is not yet finished. It is not working for me. What I observed is that each new instance of a process is getting 1 as the process instance id?

This is what I did:

(1) I configured persistence.xml to use mysql. 
(2) I start an instance of process ( https://github.com/krisv/jbpm/blob/master/jbpm-bpmn2/src/test/resources/BPMN2-EventBasedSplit.bpmn2 BPMN2-EventBasedSplit.bpmn2) by running testEventBasedSplit() of org/jbpm/bpmn2/StandaloneBPMNProcessTest, and run it till just before sending Yes signal.
(3) I create another instance of above process and do the same as step (2),

So at this point there should be two process instance which are not yet completed.What I am observing is that two process instance in PROCESSINSTANCELOG have same process instance id. I tried creating one session StatefulKnowledgeSession with two instance and they are getting same instance id. 

So when I recreate StatefulKnowledgeSession by using existing sessionid of database, I only get one process instance from the api which returns list of process instance.

Other thing I have noticed is that PROCESSINSTANCEINFO is always empty and no row is inserted there, could this be an issue?

I was able to configure history log to start saving , NODEINSTANCELOG, variable and PROCESSINSTANCELO, I am not sure why PROCESSINSTANCELOG is empty?

Maybe I am missing something, I am new to jbpm and trying to evaluate if we should use jbpm5 or stick to jbpm4.4 for sometime.


Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110114/ce2193fd/attachment-0001.html 

More information about the jboss-user mailing list