[jboss-user] [JBoss Web Services] - Web Service deployment failed after JSF update

Baradon Terendil do-not-reply at jboss.com
Tue Jan 18 10:19:39 EST 2011

Baradon Terendil [http://community.jboss.org/people/baradon] created the discussion

"Web Service deployment failed after JSF update"

To view the discussion, visit: http://community.jboss.org/message/581583#581583


I have a problem with deployment of EJB3 web service after upgrading JSF.  IMHO, these two things should not be linked to each other, but reality has a different opinion  :0 .

I'm running JBoss AS 5.1.0 GA and updated JSF to 2.0 (Mojarra 2.0.3).  Deploying any WAR works perfect, but when I deploy a JAR package containing a web sevice, I get the following error:

> Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener
> com.sun.faces.config.ConfigurationException: no web.xml present

Well, thats right.  There is no web.xml, as there must not be a web.xml in a JAR file.  Unfortunately, it prevents my complete EJB-package from beeing deployed and started.  I tried to add an empty web.xml file.  As a result, I didn't get any error message, but the application is still not started, web service not initialized, ...

Is there any workaround possible?

Best regards,


Reply to this message by going to Community

Start a new discussion in JBoss Web Services at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110118/3bd80be6/attachment.html 

More information about the jboss-user mailing list