[jboss-user] [JBoss Tools] - Cannot find the ODA dataSource extension (org.jboss.tools.birt.oda).

pretorga do-not-reply at jboss.com
Mon Jul 4 18:15:20 EDT 2011

pretorga [http://community.jboss.org/people/pretorga] created the discussion

"Cannot find the ODA dataSource extension (org.jboss.tools.birt.oda)."

To view the discussion, visit: http://community.jboss.org/message/613341#613341


I have a Seam application that uses BIRT and deploys to JBoss AS.

I created a BIRT report using the JBoss Tools Report Designer, and created a Hibernate ODA datasource. Ultimately, I have kept referring back to various versions of this reference:  http://docs.jboss.org/tools/latest-dev/en/jboss_birt_plugin_ref_guide/html/tasks.html http://docs.jboss.org/tools/latest-dev/en/jboss_birt_plugin_ref_guide/html/tasks.html

The report runs fine in Eclipse, but I get the following error when deploying to JBoss AS (1.6 currently).

*Table (id = 45):*
*+ An exception occurred during processing. Please see the following message for details:*
*Cannot find or process the org.jboss.tools.birt.oda driver's data source extension configuration.*
*Cannot find the ODA dataSource extension (org.jboss.tools.birt.oda).*
 *Check the workspace log file for any problems with loading the extension bundle and its dependencies.*

(full output here ->  http://pastebin.com/jAGSS2p0 http://pastebin.com/jAGSS2p0 )*

Now I haven't quoted specific versions of the libraries I've been using. I have had this same error using JBoss Tools 3.2 and more recently JBoss Tools 3.3 (to test the latest BIRT release). And the default WebExampleViewer for BIRT runs just fine in my application server.

>From Google and various forums (*Jboss.org*/*Eclipse.org*/*BIRT-Exchange.org*, and even *Hibernate.org*), I've found other users having exactly the same issue, going back as far as 2005, and for the most part no conclusive answer as to what causes this problem. Even recently on this and the other listed forums, these questions now just seem to go completely unanswered.

I've worked through all the items listed in these various posts, tried the various suggestions, and my problem still persists. 

One thing that has never explicitly been stated in the reference material, or these other posts, is whether or not the user is expected to implement their own ODA plugin (for Hibernate in this case), or whether the one supplied by JBoss Tools (as per the UI Report Designer in Eclipse) is sufficient for deployment as well. There is no *org.jboss.tools.birt.oda*.*hibernate* plugin that ships with JBoss Tools. Surely if the UI component (in the IDE) works, there is a related runtime enabling it to work when deployed to an application server (or wherever else it is used).

Is the end user expected to develop their own hibernate plugin, or should this all be working out of the box? 

 And if so, why does this one specific problem occur so frequently, yet rarely is the root cause of this problem explicitly identified.

I hope someone can shed some light on this issue for me.

Reply to this message by going to Community

Start a new discussion in JBoss Tools at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110704/8f3bbb84/attachment-0001.html 

More information about the jboss-user mailing list