[jboss-user] [jBPM] - fingGroupTasks method on taskService fails

Vasu Bathina do-not-reply at jboss.com
Tue Jul 12 01:38:10 EDT 2011

Vasu Bathina [http://community.jboss.org/people/vasubabu76] created the discussion

"fingGroupTasks method on taskService fails"

To view the discussion, visit: http://community.jboss.org/message/614568#614568

We are using jbpm4.4 with DB2 as database. When there are large number of opentasks for a group, then a call to taskService.findGroupTasks fails.
The DB2 SQL code is 54001 which says the query is too long or complex.
Upon further investigation, we found that the api call is translation into a sql query that has in clause. If we reduce the number of tasks, the methods runs fine.

I am wondering if there is any alternate implementation method or combination of methods that uses a join between participations and tasks rather than using a in clause ?

Appreciate if anyone who faced similar problems and solved/worked around this can share their experience.


Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110712/5dd84ec5/attachment-0001.html 

More information about the jboss-user mailing list