[jboss-user] [JBoss Tools] - Re: Eclipse indigo JBoss AS 7 deploy problem

Zoltan Baji do-not-reply at jboss.com
Thu Nov 10 10:17:10 EST 2011

Zoltan Baji [http://community.jboss.org/people/zzzooo] created the discussion

"Re: Eclipse indigo JBoss AS 7 deploy problem"

To view the discussion, visit: http://community.jboss.org/message/635953#635953

I also tried that many times - it didn't help.

The situation:
I had too different repository under the svn. Both of them had a (maven) parent project: let it parent1 and parent2.
We group the versions and repository references in these parent projects' pom files.
Under these parent projects has many different projects.
Under the parent1 we had projects, which are a kind of company framework elements.
Under the parent2 we had projects, which are specific for a customer, and they references for the framework projects (here I have the deployable ear project as well).

I checked out these parents and it's child projects, and build them from command line with maven (3.0.3) (java version: 1.6.0_26). I have Ubuntu 10.10. 
After this, I imported them as existing maven projects into eclipse. First, the parent1 with it's child projects and then the parent2 with it's child projects. After this, I created a new server instance - JBoss 7 - referencing to my own JBoss. Then I deployed, and the mentioned problem happend...

We tried this in 3 different computer with the same environment except the op. sys. (Ubuntu 10.04, Ubuntu 11.10, Mac - OSX). The Ubuntu 10.04 was mine, and the Mac had the same issue. But on the Ubuntu 11.10 was ok. After this, we compared the differences, and realized the solution. I don't think the op.sys is the responsible for this problem, but I tried to import the projects more times, and the same issue happend - also on the Mac. I really don't know what would cause this, but after when I fixed the org.eclipse.wst.common.component file manually it worked fine. So I guess the problem was with the m2eclipse or with the wst. Maybe the our settings were different - I don't know.

Reply to this message by going to Community

Start a new discussion in JBoss Tools at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20111110/1b5a4b20/attachment.html 

More information about the jboss-user mailing list