[jboss-user] [JBoss Web Services] - JAX-WS webservices are not working in JBoss-5.1.0.GA or JBoss-eap-5.1

Basavaraj Patil do-not-reply at jboss.com
Fri Nov 11 09:47:59 EST 2011

Basavaraj Patil [http://community.jboss.org/people/patilbh] created the discussion

"JAX-WS webservices are not working in JBoss-5.1.0.GA or JBoss-eap-5.1"

To view the discussion, visit: http://community.jboss.org/message/636139#636139


JAX-WS is not working in JBoss 5.1.0.GA and JBoss-eap-5.1 version. I tried with default JBoss native stack and JBoss CXF stack.

Brief Details:
Earlier we used Axis1.4 for webservices now I modified WebServices using JAX-WS which Oracle JDK 1.6 provides, deployment works fine in JBoss 4.x, WebLogic 10.x, WebSphere 7.x and WSDLs are exposed properly. The same deployment WAR file did not work in JBoss-5.1.0.GA and JBoss-eap-5.1. So i tried debugging my code, request is coming till doGet() method in my WSServlet class and then it goes within JBoss Servlet class, from here onwards I am clueless because no errors thrown.
Note: Earlier webservices using Axis 1.4 works great in Jboss-5.1.0.GA and Jboss-eap-5.1

web.xml details as below:
<description>Test Listener</description>
Please go through attachments for WSContextListener.java and WSSServlet.java detail

Error Details:
Strange thing is, I am not getting any errors in log file as well on the browser, getting blank page on browser (I mean complete white web page).

Options I tried:
I tried disabling security details in security-jboss-beans.xml and security-policies-jboss-beans.xml (security under deploy folder) thinking that anything is blocking related to security.
Also I tried disabling jboss-web.xml from jbossws-console.war folder in deploy, but did not help much.

Can you please let me know views? Also please let me know anything I am missing or need more information to understand this issue.

Reply to this message by going to Community

Start a new discussion in JBoss Web Services at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20111111/2e13773e/attachment.html 

More information about the jboss-user mailing list