[jboss-user] [IronJacamar] - Ironjacamar, IBM JDK and javax.xml.stream.XMLInputFactory

jörg maurer do-not-reply at jboss.com
Tue Nov 22 14:43:31 EST 2011

jörg maurer [http://community.jboss.org/people/liegler.maurer] created the discussion

"Ironjacamar, IBM JDK and javax.xml.stream.XMLInputFactory"

To view the discussion, visit: http://community.jboss.org/message/637796#637796

Hi all,

Tried Ironjacamar in embedded mode, Version 1.0.0Final on IBM JDK and got:

Caused by: javax.xml.stream.FactoryConfigurationError: Provider
com.sun.xml.internal.stream.XMLInputFactoryImpl not found
    at javax.xml.stream.XMLInputFactory.newInstance(Unknown Source)
    ... 8 more
Caused by: java.lang.ClassNotFoundException:
    at java.lang.Class.forName(Class.java:139)
    at javax.xml.stream.FactoryFinder.newInstance(Unknown Source)
    at javax.xml.stream.FactoryFinder.find(Unknown Source)
    at javax.xml.stream.FactoryFinder.find(Unknown Source)
    ... 10 more

After some searching and head pounding i found com.github.fungal.impl.KernelImpl, Method startup:


As i worked around this using the Woodstox Stax Impl, i can see no reason why this is hardcoded and should be dependent on that Stax Impl.

If any Ironjacmar Teammember may see it also that way - and if its is not fixed sind 1.0.0Final - pls add that fix to your 1.0.6 Release Roadmap.


Btw. is there a planned release date for 1.0.6Final, as we also would like to see if the usage of the Tuxedo JCA Adapter is now possible and fixed?

Reply to this message by going to Community

Start a new discussion in IronJacamar at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20111122/61ace1b3/attachment-0001.html 

More information about the jboss-user mailing list