[jboss-user] [Beginner's Corner] - Re: Migrating Applications from Tomcat 6 to Jboss AS 5.1

Bruce Klein do-not-reply at jboss.com
Thu Sep 29 07:00:00 EDT 2011

Bruce Klein [http://community.jboss.org/people/bklein33] created the discussion

"Re: Migrating Applications from Tomcat 6 to Jboss AS 5.1"

To view the discussion, visit: http://community.jboss.org/message/629088#629088

Hi Wolfgang,

Yes. I found that file and inserted a taglib to my web.xml and moved the file into my WEB_INF/tld directory

       <taglib-uri> http://tiles.apache.org/tags-tiles http://tiles.apache.org/tags-tiles</taglib-uri>

That solved the immediate issue but then jboss produced the following error:

org.apache.jasper.JasperException: The absolute uri:  http://java.sun.com/jsp/jstl/functions http://java.sun.com/jsp/jstl/functions cannot be resolved in either web.xml or the jar files deployed with this application

So there seems to be a pattern here. None of these tld issues exist when I run my apps in a pure Tomcat environment so I am curious as to why they are showing up by dropping these wars into jboss. What I've done so far after dropping my war file into my servers deploy dir is created a WEB-INF/jboss-classloading.xml file with the following contents to isolate my war's classes.

<?xml version="1.0" encoding="UTF-8"?>
<classloading xmlns="urn:jboss:classloading:1.0"

Whats happening in jboss to cause these issues?

Is there a more global solution to fix this or do I have to go through one by one and find the tld files and create a taglib for each one that comes up in error?


Reply to this message by going to Community

Start a new discussion in Beginner's Corner at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110929/3788b426/attachment.html 

More information about the jboss-user mailing list