[jboss-user] [jBPM] - errors when starting up jbpm 5.4-SNAPSHOT release

Satya Dhanushkodi do-not-reply at jboss.com
Fri Aug 31 16:05:48 EDT 2012

Satya Dhanushkodi [https://community.jboss.org/people/satyand] created the discussion

"errors when starting up jbpm 5.4-SNAPSHOT release"

To view the discussion, visit: https://community.jboss.org/message/757362#757362

I am getting the attached errors when deploying jbpm 5-4-SNAPSHOT and guvnor-distribution-wars-5.5.0-SNAPSHOT. I was trying to get around some of the issues related to userid and groupid in human-task-war by working with the snapshots.

Although at the startup, most of the errors are warnings about janino compiler or jaxb classes missing, ultimately when I try to import the "Employee Evaluation" example in guvnor and try to start the process, I am seeing the following message:

11:34:06,292 SEVERE [org.jboss.resteasy.core.SynchronousDispatcher] (http-localhost- failed to execute: javax.ws.rs.WebApplicationException
 at org.drools.guvnor.server.jaxrs.PackageResource.getAssetAsAtom(PackageResource.java:525) [guvnor-webapp-core-5.5.0-SNAPSHOT.jar:]
 at org.drools.guvnor.server.jaxrs.PackageResource$Proxy$_$$_WeldClientProxy.getAssetAsAtom(PackageResource$Proxy$_$$_WeldClientProxy.java) [guvnor-webapp-core-5.5.0-SNAPSHOT.jar:]
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [:1.6.0_05]

The process starts up - but the process form does not show up.

In addition, I see the following when jbpm-console starts and attempts to read from guvnor.

11:29:51,931 ERROR [stderr] (http-localhost- Caused by: java.io.InvalidClassException: org.drools.rule.MVELDialectRuntimeData; local class incompatible: stream classdesc serialVersionUID = 5166066541265170937, local class serialVersionUID = -2603821288794910940
11:29:51,931 ERROR [stderr] (http-localhost-  at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:562)
11:29:51,931 ERROR [stderr] (http-localhost-  at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1583)

I tried ensuring that the same version of drools-core is in both guvnor and jbpm-console - still same error.

Any ideas on what could be going wrong?


Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20120831/92d530be/attachment.html 

More information about the jboss-user mailing list