[jboss-user] [IronJacamar] - Classloading Issues

sacarro do-not-reply at jboss.com
Mon Dec 10 13:11:15 EST 2012

sacarro [https://community.jboss.org/people/sacarro] created the discussion

"Classloading Issues"

To view the discussion, visit: https://community.jboss.org/message/782655#782655

I am deploying an inbound/outbound enabled resource adapter (test.rar) and an Singleton Session EJB in a standalone jar (ejb-test.jar).

Within the resource adapter, I have included an ironjacamar.xml that defines the connection definition. When I deploy the rar, I see the connection factory get bound to the correct JNDI name. 

Within the EJB, I include in MANIFEST.MF the line "Dependencies: deployment.test.rar", and additionally annotate the Singleton Session Bean with "@ResourceAdapter("test.rar")". Within tje Singleton Session Bean class, I have an @Resource annotation with the mappedName property set to the bound name from the resource adapter deployment. 

When I deploy the EJB however, I still get a class not found exception from the @Resource injected class. Am I missing a step? I am running with the latest 7.1.1 JBoss AS baseline. I have also tried using the jboss-ejb3.xml with no luck.

Reply to this message by going to Community

Start a new discussion in IronJacamar at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20121210/6168474d/attachment.html 

More information about the jboss-user mailing list