[jboss-user] [jBPM] - Re: JBPM stuck when reach AdHocSubprocess and stop executing when reach IntermediateThrowEvent

Kiattchai Preecha-anusond do-not-reply at jboss.com
Fri Feb 24 02:00:27 EST 2012

Kiattchai Preecha-anusond [https://community.jboss.org/people/kiattchaipr] created the discussion

"Re: JBPM stuck when reach AdHocSubprocess and stop executing when reach IntermediateThrowEvent"

To view the discussion, visit: https://community.jboss.org/message/719354#719354

Thank you Esteban Aliverti for your help.

I take a look at the tests as your suggestion. Now, I can trigger the ScriptTask inside the AdHocSubProcess by using kSession.signalEvent("ScriptTask", null, activeProcessInstance.getId());. However, the JBPM did not return to EndEvent in the Process after the ScriptTask was triggered. I tried to using mKSession.signalEvent("EndEvent", null, activeProcessInstance.getId()); but it did not work. It seem that the ScriptTask was triggered but not completed. Additional, I tried to run the testAdHocSubProcess() at the test and found that the ScriptTask named "Goodbye" was not triggered same as the EndEvent in my Process too. Is it a JBPM bug? Or I miss something?

Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20120224/57531a3c/attachment-0001.html 

More information about the jboss-user mailing list