[jboss-user] [Beginner's Corner] - HTTP Status 404 - Could not find resource for relative :

Josiah Haswell do-not-reply at jboss.com
Wed Jan 9 22:11:25 EST 2013

Josiah Haswell [https://community.jboss.org/people/haswellj] created the discussion

"HTTP Status 404 - Could not find resource for relative :"

To view the discussion, visit: https://community.jboss.org/message/789964#789964

Hi everyone,

I've been Googling around for this, and none of the solutions I've found have worked for me.  I'm trying to build a RESTEasy-enabled application on Jboss 7.1.1 with Gradle.  I have the relevant configuration detailed towards the bottom of the message, but I see that the application is being deployed in the logs when I visit that URL:

19:43:46,458 INFO  [org.jboss.web] (MSC service thread 1-1) JBAS018210: Registering web context: /impl
19:43:46,474 INFO  [org.jboss.as.server] (HttpManagementService-threads - 4) JBAS018559: Deployed "impl.war"
19:43:53,533 INFO  [org.jboss.resteasy.cdi.CdiInjectorFactory] (http-- Found BeanManager at java:comp/BeanManager
19:43:53,542 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-- Deploying javax.ws.rs.core.Application: class example.JaxRsActivator$Proxy$_$$_WeldClientProxy

But I receive the following error when I deploy the WAR and visit  http://localhost:8080/impl/rest/user/list: http://localhost:8080/impl/rest/user/list:

*HTTP Status 404 - Could not find resource for relative : /user/list of full path:*

I do not see any errors in the log.  I've tried various permutations on omitting or adding the "/" before the paths--does this matter? 
What am I doing wrong?  




src/main/webapp/WEB-INF/web.xml (empty except for the opening/closing tags)


public class JaxRsActivator extends Application


public class UserEndpoint

    UserService userService;

    List<User> list() {
        User user = new User();
        return new ArrayList<User>(Arrays.asList(user));


Reply to this message by going to Community

Start a new discussion in Beginner's Corner at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20130109/153f16d8/attachment.html 

More information about the jboss-user mailing list