[jboss-user] [jBPM] - Is Drools/JBPM Tooling for Eclipse broken with JPAKnowledgeService?

Jim Beam do-not-reply at jboss.com
Wed Mar 13 16:17:50 EDT 2013

Jim Beam [https://community.jboss.org/people/jamesbeam] created the discussion

"Is Drools/JBPM Tooling for Eclipse broken with JPAKnowledgeService?"

To view the discussion, visit: https://community.jboss.org/message/802472#802472

I am trying to use the Drools/JBPM tooling to test a simple program with jBPM 5.4.  I tried this in Eclipse Helios and Juno.

If I create the ksession using kbase.newStatefulKnowledgeSession() the drools views work as expected - the process and process instances show the correct information (after I click on the ksession in the variables window of course).  However, this does NOT work if I create the the ksession using the JPAKnowledgeService.

Is this a known issue/limitation?  Am I missing something?

    KnowledgeBuilder kbuilder = KnowledgeBuilderFactory.newKnowledgeBuilder();
    Environment env = KnowledgeBaseFactory.newEnvironment();

    StatefulKnowledgeSession ksession = kbase.newStatuefulKnowledgeSession(); *  <-- THIS WORKS FINE*

     --- BUT --

  StatefulKnowledgeSession ksession = JPAKnowledgeService.newStatefulKnowledgeSession(kbase,null,env);*  <---THIS DOES NOT*

Note, when I use the JPAKnowledgeService, my app does function correctly (I see the session being updated in the database, etc).

Also, I tried creating the first ksession above first (calling it ksession2) and then setting ksession2=ksession, and everything works until the assignment, then the tooling stops responding.

Any thoughts on how to get this to work with

Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20130313/8d1ff641/attachment.html 

More information about the jboss-user mailing list