<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<body link="#355491" alink="#4262a1" vlink="#355491" style="background: #e2e2e2; margin: 0; padding: 20px;">

<div>
        <table cellpadding="0" bgcolor="#FFFFFF" border="0" cellspacing="0" style="border: 1px solid #dadada; margin-bottom: 30px; width: 100%; -moz-border-radius: 6px; -webkit-border-radius: 6px;">
                <tbody>
                        <tr>

                                <td>

                                        <table border="0" cellpadding="0" cellspacing="0" bgcolor="#FFFFFF" style="border: solid 2px #ccc; background: #dadada; width: 100%; -moz-border-radius: 6px; -webkit-border-radius: 6px;">
                                                <tbody>
                                                        <tr>
                                                                <td bgcolor="#000000" valign="middle" height="58px" style="border-bottom: 1px solid #ccc; padding: 20px; -moz-border-radius-topleft: 3px; -moz-border-radius-topright: 3px; -webkit-border-top-right-radius: 5px; -webkit-border-top-left-radius: 5px;">
                                                                        <h1 style="color: #333333; font: bold 22px Arial, Helvetica, sans-serif; margin: 0; display: block !important;">
                                                                        <!-- To have a header image/logo replace the name below with your img tag -->
                                                                        <!-- Email clients will render the images when the message is read so any image -->
                                                                        <!-- must be made available on a public server, so that all recipients can load the image. -->
                                                                        <a href="http://community.jboss.org/index.jspa" style="text-decoration: none; color: #E1E1E1">JBoss Community</a></h1>
                                                                </td>

                                                        </tr>
                                                        <tr>
                                                                <td bgcolor="#FFFFFF" style="font: normal 12px Arial, Helvetica, sans-serif; color:#333333; padding: 20px;  -moz-border-radius-bottomleft: 4px; -moz-border-radius-bottomright: 4px; -webkit-border-bottom-right-radius: 5px; -webkit-border-bottom-left-radius: 5px;"><h3 style="margin: 10px 0 5px; font-size: 17px; font-weight: normal;">
    SmokeTestJBToolsServerSupport
</h3>
<span style="margin-bottom: 10px;">
    created by <a href="http://community.jboss.org/people/rob.stryker%40jboss.com">Rob Stryker</a> in <i>JBoss Tools</i> - <a href="http://community.jboss.org/docs/DOC-16022">View the full document</a>
</span>
<hr style="margin: 20px 0; border: none; background-color: #dadada; height: 1px;">

<div class="jive-rendered-content"><p><span style="font-size: 14pt;"><strong>Smoke Testing JBoss Tools support for Application Servers</strong></span></p><p style="min-height: 8pt; height: 8pt; padding: 0px;">&#160;</p><p>1) Open recent JBoss Tools<br/>2) open servers view (window -&gt; show view -&gt; other -&gt; Servers)<br/>3) create new server<br/>&#160;&#160;&#160;&#160; - type: JBoss Community -&gt; JBoss AS 6.0<br/>&#160;&#160;&#160;&#160; - use default configuration<br/>&#160;&#160;&#160;&#160;&#160; - finish wizard</p><p>4) double-click server in servers view to open the server editor<br/>5) in editor, verify all server ports are accurate (JNDI / Web / JMX RMI) (right side of editor)</p><p>6) click "open launch configuration" in the editor, verify launch configuration arguments and vm args match with what is expected</p><p>&#160;&#160;&#160;&#160;&#160;&#160;&#160;&#160; a) *** If there are any new arguments that have changed since the previous AS version, MAKE SURE the launch configuration HAS them!<br/>7) In servers view, expand hte server and look at XML Configuration/Ports, verify all labels have a number next to them</p><p>8) Start server, verify when server is up and running, the servers view says "Started" and not "Starting"<br/>9) Create a project (seam or dynamic web is fine, seam project is better)<br/>10) Deploy it to the server, Verify the deployment works<br/>11) remove deployment, verify console shows deployment removed<br/>12) Open MBean Viewer,</p><p>&#160;&#160;&#160;&#160; a) note that the server can now be expanded,</p><p>&#160;&#160;&#160;&#160; b) under it are mbeans. browse down to jboss.deployment -&gt; URL -&gt;DeploymentScanner,</p><p>&#160;&#160;&#160;&#160; c) double-click DeploymentScanner, go to "Operations" page, click "stop" in viewer, click "stop" button on the right,</p><p>&#160;&#160;&#160;&#160; d) verify operation completes successfully<br/>13) in eclipse, deploy seam application again, verify console shows NO OUTPUT, deployment does NOT deploy<br/>14) use mbean viewer / editor to execute start() operation on DeploymentScaner<br/>15) verify console now accepts deployment<br/>16) stop server, verify server shuts down properly without error.</p></div>

<div style="background-color: #f4f4f4; padding: 10px; margin-top: 20px;">
    <p style="margin: 0;">Comment by <a href="http://community.jboss.org/docs/DOC-16022">going to Community</a></p>

        <p style="margin: 0;">Create a new document in JBoss Tools at <a href="http://community.jboss.org/choose-container!input.jspa?contentType=102&containerType=14&container=2128">Community</a></p>
</div></td>
                        </tr>
                    </tbody>
                </table>


                </td>
            </tr>
        </tbody>
    </table>

</div>

</body>
</html>