<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<body link="#355491" alink="#4262a1" vlink="#355491" style="background: #e2e2e2; margin: 0; padding: 20px;">

<div>
        <table cellpadding="0" bgcolor="#FFFFFF" border="0" cellspacing="0" style="border: 1px solid #dadada; margin-bottom: 30px; width: 100%; -moz-border-radius: 6px; -webkit-border-radius: 6px;">
                <tbody>
                        <tr>

                                <td>

                                        <table border="0" cellpadding="0" cellspacing="0" bgcolor="#FFFFFF" style="border: solid 2px #ccc; background: #dadada; width: 100%; -moz-border-radius: 6px; -webkit-border-radius: 6px;">
                                                <tbody>
                                                        <tr>
                                                                <td bgcolor="#000000" valign="middle" height="58px" style="border-bottom: 1px solid #ccc; padding: 20px; -moz-border-radius-topleft: 3px; -moz-border-radius-topright: 3px; -webkit-border-top-right-radius: 5px; -webkit-border-top-left-radius: 5px;">
                                                                        <h1 style="color: #333333; font: bold 22px Arial, Helvetica, sans-serif; margin: 0; display: block !important;">
                                                                        <!-- To have a header image/logo replace the name below with your img tag -->
                                                                        <!-- Email clients will render the images when the message is read so any image -->
                                                                        <!-- must be made available on a public server, so that all recipients can load the image. -->
                                                                        <a href="http://community.jboss.org/index.jspa" style="text-decoration: none; color: #E1E1E1">JBoss Community</a></h1>
                                                                </td>

                                                        </tr>
                                                        <tr>
                                                                <td bgcolor="#FFFFFF" style="font: normal 12px Arial, Helvetica, sans-serif; color:#333333; padding: 20px;  -moz-border-radius-bottomleft: 4px; -moz-border-radius-bottomright: 4px; -webkit-border-bottom-right-radius: 5px; -webkit-border-bottom-left-radius: 5px;"><h3 style="margin: 10px 0 5px; font-size: 17px; font-weight: normal;">
    Problem signing a web service request
</h3>
<span style="margin-bottom: 10px;">
    created by <a href="http://community.jboss.org/people/earnest.dyke">Earnest Dyke</a> in <i>JBoss Web Services</i> - <a href="http://community.jboss.org/message/575966#575966">View the full discussion</a>
</span>
<hr style="margin: 20px 0; border: none; background-color: #dadada; height: 1px;">

<div class="jive-rendered-content"><p>Greetings all,</p><p style="min-height: 8pt; height: 8pt; padding: 0px;">&#160;</p><p>We are running JBoss EAP 5.0 with JDK 1.6 on Windows. There is a web service on an Ubuntu/Apache server somewhere in the cloud that we need to call over https. We have everything working but the call fails and returns fault code <strong>The signature or decryption was invalid</strong>. The soap body that is generated by our client running in JBoss is as follows:</p><p style="min-height: 8pt; height: 8pt; padding: 0px;">&#160;</p><div><div class="c" style="margin-left: 1em; text-indent: -2em;">{code:xml}&lt;soapenv:Body&#160; wsu:Id="<strong>id-12001189</strong>" xmlns:wsu="<strong class="ns"><a class="jive-link-external-small" href="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" target="_blank">http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd</a></strong>"&gt;</div><div><div class="e"><div class="c" style="margin-left: 1em; text-indent: -2em;"><a class="" href="http://community.jboss.org/post!input.jspa?containerType=14&amp;container=2044#">-</a> &lt;ns1:sEncrypt_Input xmlns="<strong class="ns"><a class="jive-link-external-small" href="http://paymetric/2007-07/XiSecureWS.xsd" target="_blank">http://paymetric/2007-07/XiSecureWS.xsd</a></strong>" xmlns:ns1="<strong class="ns"><a class="jive-link-external-small" href="http://paymetric/2007-07/XiSecureWS.xsd" target="_blank">http://paymetric/2007-07/XiSecureWS.xsd</a></strong>"&gt;</div><div><div class="e"><div style="margin-left: 1em; text-indent: -2em;">&#160; &lt;ns1:MaxUnmaskedDigits&gt;4&lt;/ns1:MaxUnmaskedDigits&gt;</div></div><div class="e"><div style="margin-left: 1em; text-indent: -2em;">&#160; &lt;ns1:isUnmaskedFromLeft&gt;0&lt;/ns1:isUnmaskedFromLeft&gt;</div></div><div class="e"><div>&#160; &lt;ns1:strRawValue&gt;4545111111111111&lt;/ns1:strRawValue&gt;</div><div>&lt;/ns1:sEncrypt_Input&gt;</div></div></div></div><div>&#160; &lt;/soapenv:Body&gt;{code}</div></div><div> </div><div>We can pass this body through SoapUI and get the same response. If we pass this body through SoapUI, the service returns a valid response.</div><div> </div><div class="c" style="margin-left: 1em; text-indent: -2em;">{code:xml}&lt;soapenv:Body&#160; wsu:Id="<strong>id-12618762</strong>" xmlns:wsu="<strong class="ns"><a class="jive-link-external-small" href="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" target="_blank">http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd</a></strong>"&gt;</div><div><div class="e"><div class="c" style="margin-left: 1em; text-indent: -2em;"><a class="" href="http://community.jboss.org/post!input.jspa?containerType=14&amp;container=2044#">-</a> &lt;xis:sEncrypt_Input&gt;</div><div><div class="e"><div style="margin-left: 1em; text-indent: -2em;">&#160; &lt;xis:MaxUnmaskedDigits&gt;4&lt;/xis:MaxUnmaskedDigits&gt;</div></div><div class="e"><div style="margin-left: 1em; text-indent: -2em;">&#160; &lt;xis:isUnmaskedFromLeft&gt;0&lt;/xis:isUnmaskedFromLeft&gt;</div></div><div class="e"><div style="margin-left: 1em; text-indent: -2em;">&#160; &lt;xis:strRawValue&gt;4545111111111111&lt;/xis:strRawValue&gt;</div></div><div>&#160; &lt;/xis:sEncrypt_Input&gt;</div></div></div><div>&#160; &lt;/soapenv:Body&gt;{code}</div></div><div><br/><div><div> </div><div>The only real difference is the namespaces. Can anyone tell me why this is happening and how I can get our JBoss client to generate a body in the later format?</div><div> </div><div>Thanks in advance for any and all relevant responses.</div><div> </div><div>Earnie!</div></div></div></div></div>

<div style="background-color: #f4f4f4; padding: 10px; margin-top: 20px;">
    <p style="margin: 0;">Reply to this message by <a href="http://community.jboss.org/message/575966#575966">going to Community</a></p>
        <p style="margin: 0;">Start a new discussion in JBoss Web Services at <a href="http://community.jboss.org/choose-container!input.jspa?contentType=1&containerType=14&container=2044">Community</a></p>
</div></td>
                        </tr>
                    </tbody>
                </table>


                </td>
            </tr>
        </tbody>
    </table>

</div>

</body>
</html>