[jbosscache-commits] JBoss Cache SVN: r7816 - core/branches/flat/src/main/java/org/horizon/logging.

jbosscache-commits at lists.jboss.org jbosscache-commits at lists.jboss.org
Mon Mar 2 04:46:47 EST 2009


Author: manik.surtani at jboss.com
Date: 2009-03-02 04:46:47 -0500 (Mon, 02 Mar 2009)
New Revision: 7816

Modified:
   core/branches/flat/src/main/java/org/horizon/logging/Log.java
Log:
Javadocs

Modified: core/branches/flat/src/main/java/org/horizon/logging/Log.java
===================================================================
--- core/branches/flat/src/main/java/org/horizon/logging/Log.java	2009-03-02 09:32:32 UTC (rev 7815)
+++ core/branches/flat/src/main/java/org/horizon/logging/Log.java	2009-03-02 09:46:47 UTC (rev 7816)
@@ -16,13 +16,11 @@
  * <p/>
  * ... could be replaced with ...
  * <p/>
- * <code> log.trace("This is a message {0} and some other value is {1}", message, value); </code>
+ * <code> if (log.isTraceEnabled()) log.trace("This is a message {0} and some other value is {1}", message, value);
+ * </code>
  * <p/>
- * with no performance penalty for when trace is not enabled.  This greatly enhances code readability.
+ * This greatly enhances code readability.
  * <p/>
- * However, if <tt>message</tt> or <tt>value</tt> need to be calculated especially for the log message, then the
- * <tt>isTraceEnabled()</tt> paradigm should still be used.
- * <p/>
  * If you are passing a <tt>Throwable</tt>, note that this should be passed in <i>before</i> the vararg parameter list.
  * <p/>
  *




More information about the jbosscache-commits mailing list