[jbosstools-issues] [JBoss JIRA] (JBDS-2669) rename/refactor JBDS product .feature / plugin / .product to have less confusing names

Denis Golovin (JIRA) issues at jboss.org
Tue Jan 7 14:42:32 EST 2014


    [ https://issues.jboss.org/browse/JBDS-2669?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12933997#comment-12933997 ] 

Denis Golovin edited comment on JBDS-2669 at 1/7/14 2:42 PM:
-------------------------------------------------------------

*Option D*

Plug-ins usually don't use suffix ".plugin" and it is not plug-in anymore, but bundle; *.core.* to be consistent with JBossTools Core
{code}com.jboss.jbds.product => com.jboss.jbds.core{code}
Features usually named after branding plugins w/ or w/o suffix ".feature" all our features have suffix
{code}com.jboss.jbds.product.feature => com.jboss.jbds.core.feature {code}
This is meta IU ID generated for .product file and I agree that "package" would look better here than "all" and core for consistency
{code}com.jboss.jbds.all  => com.jboss.jbds.core.package{code} 
This id I believe should match product id defined through extension point in branding plugin and it forms as <plug-in-id>.<extension-point-id>
{code}com.jboss.jbds.product.product => com.jboss.jbds.core.product{code}

                
      was (Author: dgolovin):
    *Option D*

Plug-ins usually don't use suffix ".plugin" and it is not plug-in anymore, but bundle; *.core.* to be consistent with JBossTools Core
{code}com.jboss.jbds.product => com.jboss.jbds.core{code}
Features usually named after branding plugins w/ or w/o suffix ".feature" all our features have suffix
{code}com.jboss.jbds.product.feature => com.jboss.devstudio.core.feature {code}
This is meta IU ID generated for .product file and I agree that "package" would look better here than "all" and core for consistency
{code}com.jboss.jbds.all  => com.jboss.jbds.core.package{code} 
This id I believe should match product id defined through extension point in branding plugin and it forms as <plug-in-id>.<extension-point-id>
{code}com.jboss.jbds.product.product => com.jboss.jbds.core.product{code}

                  
> rename/refactor JBDS product .feature / plugin / .product to have less confusing names
> --------------------------------------------------------------------------------------
>
>                 Key: JBDS-2669
>                 URL: https://issues.jboss.org/browse/JBDS-2669
>             Project: Developer Studio (JBoss Developer Studio)
>          Issue Type: Bug
>      Security Level: Public(Everyone can see) 
>          Components: build, installer, updatesite
>    Affects Versions: 7.0.0.GA
>            Reporter: Nick Boldt
>            Assignee: Denis Golovin
>            Priority: Critical
>             Fix For: 8.0.0.Alpha2
>
>
> We should consider some better names for these artifacts so they collide less and are more obvious which is which.
> 1. https://github.com/jbdevstudio/jbdevstudio-product/blob/master/features/com.jboss.jbds.product.feature/feature.properties
> ** featureName=JBoss Developer Studio (Core Features) / BYOE category in update site
> 2. https://github.com/jbdevstudio/jbdevstudio-product/blob/master/plugins/com.jboss.jbds.product/plugin.properties and https://github.com/jbdevstudio/jbdevstudio-product/blob/master/plugins/com.jboss.jbds.product/META-INF/MANIFEST.MF
> ** Bundle-SymbolicName: com.jboss.jbds.product;singleton:=true
> 3. https://github.com/jbdevstudio/jbdevstudio-product/blob/master/site/com.jboss.jbds.product
> ** name="JBoss Developer Studio (Branded Product)" uid="com.jboss.jbds.all" id="com.jboss.jbds.product.product"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the jbosstools-issues mailing list