[jbosstools-issues] [JBoss JIRA] (JBIDE-22283) reveng *.java emitter does not escape java keyword 'return' as variable name

Darryl Miles (JIRA) issues at jboss.org
Wed Jul 20 15:58:00 EDT 2016


    [ https://issues.jboss.org/browse/JBIDE-22283?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13268397#comment-13268397 ] 

Darryl Miles commented on JBIDE-22283:
--------------------------------------

No the issue is that the "property" name needs to be "return" this is indeed a valid name.
But the local variable name needs to be called something else (but this is autogenerated and not mechanism exists to configure it).

The property accessors code would look like:

public void setReturn(Return return_) {
 this.autoGeneratedVariableCouldNotCareLessWhatItIsCalled = return_;
}
public Return getReturn() {
 return autoGeneratedVariableCouldNotCareLessWhatItIsCalled;
}

Note the problem is not that the property should be renamed to "return_" but that the unimportant auto-generated local variables get an invalid name.  Since it is valid for a method signature getReturn() and setReturn(Return).

Does this explain better the problem is not one that can be configured around.

> reveng *.java emitter does not escape java keyword 'return' as variable name
> ----------------------------------------------------------------------------
>
>                 Key: JBIDE-22283
>                 URL: https://issues.jboss.org/browse/JBIDE-22283
>             Project: Tools (JBoss Tools)
>          Issue Type: Bug
>          Components: hibernate
>    Affects Versions: 4.3.x
>         Environment: Eclipse Mars
>            Reporter: Darryl Miles
>            Assignee: Koen Aers
>             Fix For: 4.4.1.AM2
>
>
> reveng *.java emitter does not escape java keyword 'return' as variable name
> 	<table name="oc_return_history">
> 		<foreign-key constraint-name="FK_oc_return_history__return_id" foreign-table="oc_return">
> 			<column-ref local-column="return_id" foreign-column="return_id"/>
> 			<!-- this breaks the generator trying to name local variable as a java keyword -->
> 			<many-to-one property="return"/>
> 		</foreign-key>
> 	</table>
> The expected output would be:
> private Return _return;
> but actual output is:
> private Return return;



--
This message was sent by Atlassian JIRA
(v6.4.11#64026)


More information about the jbosstools-issues mailing list