[jbossts-issues] [JBoss JIRA] (JBTM-1039) Nm: Very confusing method names (NM_VERY_CONFUSING)

Mark Little (JIRA) jira-events at lists.jboss.org
Thu May 3 09:39:17 EDT 2012

    [ https://issues.jboss.org/browse/JBTM-1039?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12690049#comment-12690049 ] 

Mark Little commented on JBTM-1039:

Users should be working with AtomicAction and friend and not directly with BasicAction. Furthermore, changing the name breaks backwards compatibility.
> Nm: Very confusing method names (NM_VERY_CONFUSING)
> ---------------------------------------------------
>                 Key: JBTM-1039
>                 URL: https://issues.jboss.org/browse/JBTM-1039
>             Project: JBoss Transaction Manager
>          Issue Type: Bug
>      Security Level: Public(Everyone can see) 
>            Reporter: Amos Feng
>            Assignee: Tom Jenkinson
> 1.ArjunaCore/arjuna
> com.arjuna.ats.arjuna.AtomicAction Line 186
> VERY confusing to have methods com.arjuna.ats.arjuna.AtomicAction.abort() and com.arjuna.ats.arjuna.coordinator.BasicAction.Abort()

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.jboss.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the jbossts-issues mailing list