[jbossts-issues] [JBoss JIRA] (JBTM-1611) Failing qa testcase org.jboss.jbossts.qa.junit.testgroup.TestGroup_crashrecovery09, 10, 12 with jacorb and HornetQ object store enabled

Ondřej Chaloupka (JIRA) jira-events at lists.jboss.org
Thu May 2 06:45:54 EDT 2013

    [ https://issues.jboss.org/browse/JBTM-1611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12771569#comment-12771569 ] 

Ondřej Chaloupka commented on JBTM-1611:


I wonder what I have been doing wrong but I'm not able to run the test without failure. I've tried 3 machines and I'm still getting failures as above. My machine is not such slow (Intel Core i7 2.7GHz, 8GM ram).
I've tried to set several values to timeoutFactor but no success here.

My steps:
# git clone -b 4.17 https://github.com/jbosstm/narayana
# cd narayana
# ./build.sh -P all -Dmaven.test.skip.exec=true
# cd qa
# ant dist
# redefinition of the TaskImpl.properties - e.g.
## COMMAND_LINE_12=-DCoreEnvironmentBean.timeoutFactor=3
## COMMAND_LINE_13=-DCoordinatorEnvironmentBean.defaultTimeout=360
# ant -f run-tests.xml -Dtest.name=crashrecovery09 -Dtest.methods=CrashRecovery09_Test01 -Dprofile=hornetq onetest

The failure which I'm getting is caused of value 0 set in the valueHolder of Client01a.java.
correct = correct && (valueHolder.value == 1);

Do you think that I have followed some step incorrectly? Or would you have an idea what to do in other way?
Thank you
> Failing qa testcase org.jboss.jbossts.qa.junit.testgroup.TestGroup_crashrecovery09,10,12 with jacorb and HornetQ object store enabled
> -------------------------------------------------------------------------------------------------------------------------------------
>                 Key: JBTM-1611
>                 URL: https://issues.jboss.org/browse/JBTM-1611
>             Project: JBoss Transaction Manager
>          Issue Type: Bug
>      Security Level: Public(Everyone can see) 
>          Components: Testing
>    Affects Versions: 4.17.3
>            Reporter: Ondřej Chaloupka
>            Assignee: Michael Musgrove
>             Fix For: 4.17.5, 5.0.0.M3
>         Attachments: 0001-JBTM-1611-Make-recovery-passes-configurable.patch
> During testing EAP 6.1.0.ER3 I'm hitting problem on QA tests of narayana project for branch 4.17 when running qa tests with jacorb and hornetq object store (happening for NIO and AIO).
> Tests which are failing:
> org.jboss.jbossts.qa.junit.testgroup.TestGroup_crashrecovery09
> - CrashRecovery09_Test01
> - CrashRecovery09_Test03
> - CrashRecovery09_Test05
> org.jboss.jbossts.qa.junit.testgroup.TestGroup_crashrecovery10
> - CrashRecovery10_Test01
> - CrashRecovery10_Test03
> - CrashRecovery10_Test05
> org.jboss.jbossts.qa.junit.testgroup.TestGroup_crashrecovery12
> - CrashRecovery12_Test03
> - CrashRecovery12_Test06
> Detailed log could be found in job:
> https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-61-jbossts-qa-test-hqobjectstore-nio/13/artifact/archive.zip
> I was trying to get more info on the test CrashRecovery09 but I can say just that the value honlder has value 0 instead of 1 on org.jboss.jbossts.qa.CrashRecovery09Clients.Client01a (line 84).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

More information about the jbossts-issues mailing list