[jbossts-issues] [JBoss JIRA] (JBTM-1971) Cannot browse logs with the LogBrowser tool

Mark Little (JIRA) jira-events at lists.jboss.org
Thu Oct 10 17:30:02 EDT 2013

    [ https://issues.jboss.org/browse/JBTM-1971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12813272#comment-12813272 ] 

Mark Little commented on JBTM-1971:

Not quite. The DEFAULT_TYPE is always meant to be a shorthand for the log type, so AtomicAction is correct. The issue is that this shorthand should have been mapped to the actual log type when used by the object store. That's what TransactionTypeManager is supposed to do, but isn't in this case.

I suggest separating this issue into two. One concerned with this short-hand and one to do with the HQ log. Assign me the former and someone else will have to look at the HQ issue because I haven't tried that before. Although I suggest working on the second after I've fixed the first in case there are any knock-on consequences.
> Cannot browse logs with the LogBrowser tool
> -------------------------------------------
>                 Key: JBTM-1971
>                 URL: https://issues.jboss.org/browse/JBTM-1971
>             Project: JBoss Transaction Manager
>          Issue Type: Bug
>      Security Level: Public(Everyone can see) 
>          Components: Tooling
>    Affects Versions: 5.0.0.M5
>            Reporter: Michael Musgrove
>            Assignee: Tom Jenkinson
>         Attachments: jstack.LogBrowser
> I tried browsing some logs using the command:
> {noformat}
> java -Dcom.arjuna.ats.arjuna.common.ObjectStoreEnvironmentBean.objectStoreDir=<path to logs> com.arjuna.ats.arjuna.tools.log.LogBrowser
> {noformat}
> This gives an interactive command line. I then had a go at listing some logs using:
> {noformat}
> -> select AtomicAction
> -> ls
> {noformat}
> The tool does not find any logs even though there are entries in the directory:
> {code}
> <path_ to_logs>/ShadowNoFileLockStore/defaultStore/StateManager/BasicAction/TwoPhaseCoordinator/AtomicAction
> {code}
> The problem is that the LogBrowser.listLogs operation uses the the type (AtomicAction) as the parameter to the call StoreManager.getRecoveryStore().allObjUids(type, buff)) but the actual type of an AtomicAction log is "/StateManager/BasicAction/TwoPhaseCoordinator/AtomicAction";
> Also running the tool to view Hornetq store logs hangs on shutdown. Debugging reveals org.hornetq.core.journal.impl.TimedBuffer waiting to aquire a semaphore (spinLimiter) in its run loop - I could not determine which thread (see attached jstack dump)

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

More information about the jbossts-issues mailing list