[keycloak-user] Cannot insert duplicate key in object 'dbo.RoleEntity'

Marek Posolda mposolda at redhat.com
Tue Jun 17 03:26:57 EDT 2014


which database are you using? Still MS-SQL?

On 17.6.2014 00:42, Dean Peterson wrote:
> I have tried to create a new Realm using beta-2 and the latest master 
> code.  I always get the same error:
> Violation of UNIQUE KEY constraint 'UK_2cek0xo8yixluudnb1njcl94d'. 
> Cannot insert duplicate key in object 'dbo.RoleEntity'. The duplicate 
> key value is (view-realm, <NULL>).
> 17:30:07,680 INFO 
>  [org.hibernate.engine.jdbc.batch.internal.AbstractBatchImpl] (default 
> task-8) HHH000010: On release of batch it still contained JDBC statements
> 17:30:07,741 ERROR [io.undertow.request] (default task-8) UT005023: 
> Exception handling request to /auth/admin/realms: 
> java.lang.IllegalStateException: Transaction not active
> _______________________________________________
> keycloak-user mailing list
> keycloak-user at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/keycloak-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/keycloak-user/attachments/20140617/06167b92/attachment.html 

More information about the keycloak-user mailing list