bayeux4netty suggestions

Luís M. Costa luis.m.costa at gmail.com
Thu Sep 3 09:16:25 EDT 2009


  Hi,

  Just a quick note to say that I'm totally in favor of a more flexible
routing mechanism.


Danny Dai wrote:
> 
> Sounds cool!  discussed names with Luís M. Costa before. Now, these
> 
> names are really very hard to understand. IMHO, the word "Event" may
> 
> imply that methods return event objects, like BayeuxRequestEvent. But
> 
> the queues only contain and return Bayeux message entities, which is
> 
> not like events.  So, I have a simple rename proposal in below:
> 
>         receiveToQueue -> putToUpstreamQueue
> 
>         sendToQueue    -> putToDownstreamQueue
> 
>         pollFromUpsream -> getFromUpstreamQueue 
> 

  I belive a more intuitive form would be using the get/put prefixes +
Input/Output + Message, such as:
        receiveToQueue -> putInputMessage
        sendToQueue    -> putOutputMessage

        pollFromUpsream -> getInputMessage 
  or, more simply:
        receiveToQueue -> putRequest
        sendToQueue    -> putResponse

        pollFromUpsream -> getRequest 
  Eventually with “Message” as sufix.

  Just a thought,
     Luís M. Costa
-- 
View this message in context: http://n2.nabble.com/bayeux4netty-suggestions-tp3563352p3573134.html
Sent from the Netty Developer Group mailing list archive at Nabble.com.



More information about the netty-dev mailing list