[richfaces-issues] [JBoss JIRA] (RF-13626) Rename the BOM artifact

Brian Leathem (JIRA) issues at jboss.org
Thu May 8 12:35:57 EDT 2014


Brian Leathem created RF-13626:
----------------------------------

             Summary: Rename the BOM artifact
                 Key: RF-13626
                 URL: https://issues.jboss.org/browse/RF-13626
             Project: RichFaces
          Issue Type: Task
      Security Level: Public (Everyone can see)
            Reporter: Brian Leathem
             Fix For: 4.5.0.Alpha3


I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename

I'd also like to rename the BOM as part of this issue.  Currently the BOM manages the following Dependency versions:
{code}
    <dependencyManagement>
        <dependencies>
            <!-- Optional cache dependencies -->
            <dependency>
                <groupId>opensymphony</groupId>
                <artifactId>oscache</artifactId>
                <version>${version.oscache}</version>
            </dependency>
            <dependency>
                <groupId>org.jboss.cache</groupId>
                <artifactId>jbosscache-core</artifactId>
                <version>${version.jbosscache}</version>
            </dependency>
            <dependency>
                <groupId>net.sf.ehcache</groupId>
                <artifactId>ehcache</artifactId>
                <version>${version.ehcache}</version>
            </dependency>
        </dependencies>
    </dependencyManagement>
{code}

Since only the cache-dependencies are managed, we could rename the BOM to {{richfaces-cache-bom}}.



--
This message was sent by Atlassian JIRA
(v6.2.3#6260)


More information about the richfaces-issues mailing list