[jbossseam-issues] [JBoss JIRA] Commented: (JBSEAM-4002) InstantiationException at Stateful bean (Could not instantiate Seam component)

Tamas Malatinszki (JIRA) jira-events at lists.jboss.org
Tue Mar 24 04:50:22 EDT 2009

    [ https://jira.jboss.org/jira/browse/JBSEAM-4002?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12458711#action_12458711 ] 

Tamas Malatinszki commented on JBSEAM-4002:

I downloaded the latest JBoss Tools (3.0.0 GA) and tried to create a new project with it, but the failure is still the same. Is the attached example working for You?

> InstantiationException at Stateful bean (Could not instantiate Seam component)
> ------------------------------------------------------------------------------
>                 Key: JBSEAM-4002
>                 URL: https://jira.jboss.org/jira/browse/JBSEAM-4002
>             Project: Seam
>          Issue Type: Bug
>          Components: EJB3
>    Affects Versions: 2.1.1.CR2, 2.1.1.GA
>         Environment: JBoss AS 4.2.2 / 4.2.3 / 5.0.0, WinXP / Debian Linux, JD1.6 update 7/11/12
>            Reporter: Tamas Malatinszki
>         Attachments: test.zip, test_source.zip
> Stateful beans are failing with "Could not instantiate Seam component" error in Seam 2.1.1 CR2 and above. The root cause is  "java.lang.ClassNotFoundException: No ClassLoaders found for: <stateful bean>". The application is working fine with Seam 2.1.1 CR1 (and before).
> See the whole stacktrace and the related code at  http://www.seamframework.org/Community/StatefulBeanErrorInSeam211GAAndCR2

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: https://jira.jboss.org/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the seam-issues mailing list