[seam-issues] [JBoss JIRA] Created: (SEAMCRON-11) Add java.util.concurrent.TimeUnit attribute on @Every

Peter Royle (JIRA) jira-events at lists.jboss.org
Thu May 12 20:30:31 EDT 2011


Add java.util.concurrent.TimeUnit attribute on @Every
-----------------------------------------------------

                 Key: SEAMCRON-11
                 URL: https://issues.jboss.org/browse/SEAMCRON-11
             Project: Seam Cron
          Issue Type: Enhancement
            Reporter: Peter Royle
            Assignee: Peter Royle


Idea courtesy of George Gastaldi. This would allow us to replace Second, Minute and Hour with the standard CronEvent for better consistency, without breaking the readability.

public void doStuff(@Observes @Every(SECONDS) CronEvent

Unfortunately there's a couple of teeny tiny hiccups:

- TimeUnit only goes up to SECONDS in JDK 1.5, and I want to support 1.5 so that Seam Cron can be used n the various CDI JavaSE flavors.
- TimeUnit values are pluralised which don't read very well, eg: @Observes @Every(HOURS)

So obviously, we just create our own replacement for TimeUnit. I guess it will have to be ... CronTimeUnit?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the seam-issues mailing list