[seam-issues] [JBoss JIRA] (JBSEAM-5143) Random IllegalArgumentException: Stack must not be null

Robert Becker (JIRA) issues at jboss.org
Fri Nov 28 05:19:39 EST 2014


    [ https://issues.jboss.org/browse/JBSEAM-5143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13023797#comment-13023797 ] 

Robert Becker commented on JBSEAM-5143:
---------------------------------------

I am currently running the latest 2.3. nightly build which did not bring any improvement for this issue.

I also removed Omnifaces completely to reduce the pool of possible causes which also changed nothing.

> Random IllegalArgumentException: Stack must not be null
> -------------------------------------------------------
>
>                 Key: JBSEAM-5143
>                 URL: https://issues.jboss.org/browse/JBSEAM-5143
>             Project: Seam 2
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.3.1.Final
>            Reporter: Robert Becker
>
> Since upgrading to Seam 2.3 with Mojarra 2.1.29 on glassfish v3 from Seam 2.2.2, I get random IllegalArgumentExceptions with the message "Stack must not be null". The application worked fine for several years until now.
> The full stack trace is listed here: http://pastebin.com/RjLndvnE
> The exception randomly happens (in about 1 of 500 requests) when navigating between pages, submitting forms, switching (RichFaces) tabs and so on.
> I believe restarting glassfish and/or enabling client side state saving reduces the frequency of the issue whereas it seems to happen more often after multiple successive redeployments during development.  Sadly, due to several dependencies this is already in production but happens far less often there, but it still happens daily according to the server logs.
> I have also posted this on stackoverflow (http://stackoverflow.com/questions/27107870/seam-2-3-illegalargumentexception-stack-must-not-be-null) but have not received any answers yet.
> Besides Seam 2.3, the following libraries are used:
> - Mojarra 2.1.29
> - RF 4.5 (exception also occurred with 4.3.x)
> - Omnifaces 1.10RC1 (will upgrade to 2.0)
> - Primefaces 5.1



--
This message was sent by Atlassian JIRA
(v6.3.8#6338)


More information about the seam-issues mailing list