[shrinkwrap-issues] [JBoss JIRA] Updated: (SHRINKWRAP-268) MavenDependencyResolver.loadReposFromPom and loadDependenciesFromPom methods are missleading

Andrew Rubinger (JIRA) jira-events at lists.jboss.org
Tue Jun 28 02:11:23 EDT 2011


     [ https://issues.jboss.org/browse/SHRINKWRAP-268?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Andrew Rubinger updated SHRINKWRAP-268:
---------------------------------------

           Status: Resolved  (was: Pull Request Sent)
    Fix Version/s: 1.0.0-beta-4
       Resolution: Done


Upstream: https://github.com/shrinkwrap/shrinkwrap/commit/dbf2b101c87c019a67270c2b5ec2b76c6dae707a

> MavenDependencyResolver.loadReposFromPom and loadDependenciesFromPom methods are missleading
> --------------------------------------------------------------------------------------------
>
>                 Key: SHRINKWRAP-268
>                 URL: https://issues.jboss.org/browse/SHRINKWRAP-268
>             Project: ShrinkWrap
>          Issue Type: Enhancement
>          Components: ext-resolver
>    Affects Versions: 1.0.0-alpha-12
>            Reporter: Karel Piwko
>            Assignee: Samuel Santos
>             Fix For: 1.0.0-beta-4
>
>
> Current state:
> {code}
> loadReposFromPom(String file) 
> {code} 
> Loads a POM file and activates all repositories present there, moreover it loads all <dependencies> into cache so user can omit version
> in artifact specification.
> => should be renamed to loadMetadataFromPom(String file) or split to loadReposFromPom(String file), loadDependencyVersionsFromPom(String file) and aggregator loadMetadataFromPom(String file)
> {code}
> loadDepedenciesFromPom(String file)
> {code}
> Loads a POM file and adds all dependencies present there to the dependency chain. This means once the resolveXYZ() is called dependencies from POM are resolved.
> => should be renamed to includeDependenciesFromPom(String file)
> {code}
> loadDependenciesFromPom(String file, MavenResolutionFilter filter)
> {code}
> Does the same as previous, filter is not used there but during resolveXYZ()
> => should be removed

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the shrinkwrap-issues mailing list