[shrinkwrap-issues] [JBoss JIRA] (SHRINKDESC-113) Move DescriptorNamespace out of the Public API

Ralf Battenfeld (JIRA) jira-events at lists.jboss.org
Thu Apr 12 07:38:48 EDT 2012


    [ https://issues.jboss.org/browse/SHRINKDESC-113?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12683450#comment-12683450 ] 

Ralf Battenfeld commented on SHRINKDESC-113:
--------------------------------------------

Fair question. I remember we discussed this a little bit here:https://community.jboss.org/message/605293#605293

The common agreement was to provide CRUD operations for the namespaces. I can think of the case that an end user wants to change the url from http:/... to file://.. for validation purposes, or to get rid of the namespaces at all.

I agree that this is of limited value, except we make a mistake by configuring the namespaces...
Personally, I would keep it and not to lock-in this. May we also should think that the metadata-parser-plugin could be used outside of the descriptors we generate. 
                
> Move DescriptorNamespace out of the Public API
> ----------------------------------------------
>
>                 Key: SHRINKDESC-113
>                 URL: https://issues.jboss.org/browse/SHRINKDESC-113
>             Project: ShrinkWrap Descriptors
>          Issue Type: Task
>            Reporter: Andrew Rubinger
>            Assignee: Andrew Rubinger
>
> This needs some discussion before being done.  It'd break backwards-compatibility with the 1.x series.
> DescriptorNamespace is mutable, which conflicts with the goals outlined in SHRINKDESC-21.  We're not really testing its direct usage at the moment, and I wonder what reason end-users would have to be invoking its operations to muck around with the "namespace" of a domain object.  Currently all descriptors are supporting its operations by extension:
> {code}public interface WebAppDescriptor extends Descriptor, DescriptorNamespace<WebAppDescriptor>{code}
> ...and the methods in question as defined by DescriptorNamespace are:
> {code}
>    public T addDefaultNamespaces();
>    public T addNamespace(String name, String value);
>    public List<String> getNamespaces();
>    public T removeAllNamespaces();{code}
> Note that Ralf's work in SHRINKDESC-21 also splits this into DescriptorNamespace and DescriptorMutableNamespace.
> My feeling is that neither should be part of the API; maybe SPI or just internals.
> Discuss if it's appropriate to remove this and break the backwards-compatibility with the 1.x series.  In this case, I'm willing to entertain this exception.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.jboss.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the shrinkwrap-issues mailing list