[windup-dev] Rename one of 2 perform()s?

Ondrej Zizka ozizka at redhat.com
Wed Jul 23 07:20:42 EDT 2014


Hi,

we have 2 perform() methods: One for the rule, one for operation.
With the anonymous inner operations, this gets confusing:

ConfigurationBuilder.begin().addRule().
        .perform(
              new Operation(
                    .perform(
                             // Nested iteration
                                     .perform(
                                                 new AnotherOperation(){
.perform( ... ){
                                                                 }// end 
perform()
                                                  }
                                     )// end perform()
                             //
                     )// end perform()
             )
       )
;

Too many perform()'s.
I know this comes from OCP. I suggest to change it there.
Name can be anything, e.g. execute(), do(), wouldYouMind(), ... :)

WDYT?
Ondra


More information about the windup-dev mailing list