[bv-dev] BVAL-436 disable executable validation altogether

Gunnar Morling gunnar at hibernate.org
Wed Mar 13 06:54:24 EDT 2013


What I like about approach #2 is that it bundles the configuration related
to executable validation in one element.

Maybe an attribute could be used for the flag:

    <executable-validation enabled="true|false">
        <default-validated-executables>
            <executable-type>NONE</executable-type>
        </default-validated-executables>
    </executable-validation>

Generally I like "positive" flag names better than negated ones (i.e.
"enabled" instead of "disabled").

If you want to stick to two elements instead of an attribute, a xs:choice
could be used to express that only one of the elements may be present in a
given instance document.

> Would isValidationExecutionDisabled() not a better name?

Or isValidationOnExecutionEnabled()?

--Gunnar



2013/3/13 Hardy Ferentschik <hardy at hibernate.org>

>
> On 13 Jan 2013, at 8:37 AM, Emmanuel Bernard <emmanuel at hibernate.org>
> wrote:
>
> > https://gist.github.com/emmanuelbernard/2191bad0c7d8742a8eea
> >
> > Approach #1 has my preference I believe.
>
> +1 A single flag works.
>
> > Likewise BootstrapConfiguration would get a Boolean
> > getDisableValidationExecution() method that is ignored by Bean
> > Validation engines proper.
>
> Would isValidationExecutionDisabled() not a better name?
>
> --Hardy
>
> _______________________________________________
> beanvalidation-dev mailing list
> beanvalidation-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/beanvalidation-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/beanvalidation-dev/attachments/20130313/1bf40262/attachment.html 


More information about the beanvalidation-dev mailing list