[JBoss JIRA] (FORGE-2486) Allow external UI validation to occur
by George Gastaldi (JIRA)
George Gastaldi created FORGE-2486:
--------------------------------------
Summary: Allow external UI validation to occur
Key: FORGE-2486
URL: https://issues.jboss.org/browse/FORGE-2486
Project: Forge
Issue Type: Feature Request
Components: UI - API
Affects Versions: 2.19.2.Final
Reporter: George Gastaldi
Assignee: George Gastaldi
Fix For: 2.19.3.Final
Some use cases require the validation of a UI to be decoupled from the {{UICommand}} implementation itself (eg: Displaying a message when a command is said to be deprecated).
It would be nice if the UI validation could occur separately from the UICommand itself.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
9 years, 3 months
[JBoss JIRA] (FORGE-2484) java-new-enum-const should follow the naming convention
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-2484?page=com.atlassian.jira.plugin... ]
George Gastaldi updated FORGE-2484:
-----------------------------------
Priority: Minor (was: Major)
> java-new-enum-const should follow the naming convention
> -------------------------------------------------------
>
> Key: FORGE-2484
> URL: https://issues.jboss.org/browse/FORGE-2484
> Project: Forge
> Issue Type: Sub-task
> Components: Java EE
> Affects Versions: 2.19.1.Final
> Reporter: Antonio Goncalves
> Priority: Minor
> Fix For: 2.x Future
>
>
> At the moment to add a new constant to an enum we type :
> {code}
> java-new-enum-const VISA ;
> {code}
> To follow the other commands, it should have a {{named}} parameter
> {code}
> java-new-enum-const --named VISA ;
> java-new-enum-const --named MASTER_CARD ;
> java-new-enum-const --named AMERICAN_EXPRESS ;
> {code}
> Changing {{new}} to {{add}} we could end up with :
> {code}
> java-add-enum-const --named VISA ;
> java-add-enum-const --named MASTER_CARD ;
> java-add-enum-const --named AMERICAN_EXPRESS ;
> {code}
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
9 years, 3 months
[JBoss JIRA] (FORGE-2484) java-new-enum-const should follow the naming convention
by George Gastaldi (JIRA)
[ https://issues.jboss.org/browse/FORGE-2484?page=com.atlassian.jira.plugin... ]
George Gastaldi commented on FORGE-2484:
----------------------------------------
The current {{java-new-enum-const}} command accepts multiple enum constants, so it's possible to do {{java-new-enum-const VISA MASTERCARD AMEX}} and generate those constants in a single execution.
Having a {{java-add-enum-const}} although interesting wouldn't add much to this command besides the nomenclature, which is a good thing.
> java-new-enum-const should follow the naming convention
> -------------------------------------------------------
>
> Key: FORGE-2484
> URL: https://issues.jboss.org/browse/FORGE-2484
> Project: Forge
> Issue Type: Sub-task
> Components: Java EE
> Affects Versions: 2.19.1.Final
> Reporter: Antonio Goncalves
> Priority: Minor
> Fix For: 2.x Future
>
>
> At the moment to add a new constant to an enum we type :
> {code}
> java-new-enum-const VISA ;
> {code}
> To follow the other commands, it should have a {{named}} parameter
> {code}
> java-new-enum-const --named VISA ;
> java-new-enum-const --named MASTER_CARD ;
> java-new-enum-const --named AMERICAN_EXPRESS ;
> {code}
> Changing {{new}} to {{add}} we could end up with :
> {code}
> java-add-enum-const --named VISA ;
> java-add-enum-const --named MASTER_CARD ;
> java-add-enum-const --named AMERICAN_EXPRESS ;
> {code}
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
9 years, 3 months
[JBoss JIRA] (FORGE-2485) Upgrade to Furnace 2.22.1.Final
by George Gastaldi (JIRA)
George Gastaldi created FORGE-2485:
--------------------------------------
Summary: Upgrade to Furnace 2.22.1.Final
Key: FORGE-2485
URL: https://issues.jboss.org/browse/FORGE-2485
Project: Forge
Issue Type: Component Upgrade
Components: Furnace (Container)
Affects Versions: 2.19.2.Final
Reporter: George Gastaldi
Assignee: George Gastaldi
Fix For: 2.19.3.Final
Support for Jandex index, Weld 2.3.0.Final and Arquillian 1.1.9.Final
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
9 years, 3 months