[forge-dev] Forge Plugin/Addon/Extension naming
koen.aers at gmail.com
Fri May 27 02:31:35 EDT 2011
In the Eclipse ecosystem such addons are called fragments.
But then I don't know if we want to add to the overload of Eclipse
On Thu, May 26, 2011 at 7:34 PM, Jason Porter <lightguard.jp at gmail.com>wrote:
> I like extension, because it's extending what's there, but naming
> conflicts arise with both Addon and Extension :( ExtensionPack maybe
> or similar?
> On Thursday, May 26, 2011, Lincoln Baxter, III <lincolnbaxter at gmail.com>
> > " Keep the Seam plugins small and
> > isolated, yet have a single plugin that is used"
> > I think we need a new name for "Plugin"... we might have to use "Addon"
> > or "Extension" to refer to the bundle that may or may not contain an
> > actual org.jboss.forge.plugins.Plugin
> > Thoughts?
> > ~Lincoln
> > --
> > Lincoln Baxter, III
> > http://ocpsoft.com
> > http://scrumshark.com
> > "Keep it Simple"
> Jason Porter
> Software Engineer
> Open Source Advocate
> Author of Seam Catch - Next Generation Java Exception Handling
> PGP key id: 926CCFF5
> PGP key available at: keyserver.net, pgp.mit.edu
> forge-dev mailing list
> forge-dev at lists.jboss.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the forge-dev