[forge-dev] Issue with Angular scaffold generation

Ivan St. Ivanov ivan.st.ivanov at gmail.com
Thu Jan 15 08:57:00 EST 2015

Hi folks,

While I was preparing tonight's demo for Barcelona JUG, I found something
really strange.

Whenever you try to generate Angular scaffold, it generates everything
besides the JAX-RS endpoints for the selected entities.

Here are the steps to reproduce it:

1) Create new project
2) Add new JPA entity, setting up Wildfly as container and taking the
defaults. Choose Conference as entity name
3) Add new field, choose name as name and leave the defaults for the other
4) Generate scaffold. Make sure you choose Angular, select the Conference
entity and click Finish

You will notice that we have all the web resources generated fine, also the
Application class (required by JAX-RS) is there, but not the stateless
session EJB, which scaffolds the conference entity.

I tried also to first setup scaffolding and then generate, but the result
was the same - no EJB.

JSF scaffolding works fine. Generating REST endpoints from entities works
fine too.

I tried this with JBDS and IntelliJ IDEA.

I am pretty sure it used to work some time ago. I demoed the same thing in
Macedonia last November and it worked.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-dev/attachments/20150115/28665415/attachment.html 

More information about the forge-dev mailing list