[forge-users] How do I run Forge shell from the code ?

George Gastaldi ggastald at redhat.com
Sun Feb 16 17:43:08 EST 2014

Hi Antonio,

There are two options:

- I usually build the whole project (tests disabled), then go into dist/target and unzip the distribution. After that I remove my ~/.forge and install the core with forge -i org.jboss.forge.addon:core,2.0.1-SNAPSHOT -b. 

- create tests using the shell-test-harness.  

There is a sh script in the forge/core root that does the unzipping but I usually do it manually.

> Em 16/02/2014, às 17:48, Antonio Goncalves <antonio.mailing at gmail.com> escreveu:
> Hi developers,
> I've cloned Forge 2 code on my local computer, I create pull/requests, test new functionalities.... But do you know how I actually run the command shell from the code ?
> If I run the org.jboss.forge.bootstrap.Bootstrap class (it has a public static void main method) the output just hangs (like when the Shell is not installed) : 
> JBoss Forge, version [ 2.0.1-SNAPSHOT ] - JBoss, by Red Hat, Inc. [ http://forge.jboss.org ]
> So I thought of passing this argument to the Bootstrap class (--install org.jboss.forge.addon:core,2.0.1-SNAPSHOT) but there is a NPE at : 
> String result = System.console().readLine("Confirm installation [Y/n]? ");
> So on debug mode I set the result to "Y" but after bootstrap.start(); the VM just stopped gently.
> I suppose the underlying question is : how do you run the shell once you have made a change and want to test it ?
> Antonio
> _______________________________________________
> forge-users mailing list
> forge-users at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/forge-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-users/attachments/20140216/282461e2/attachment.html 

More information about the forge-users mailing list