[forge-users] Trying to run Forge under Cygwin and Windows 8 -- no command is executed

forge-users at lists.jboss.org forge-users at lists.jboss.org
Mon Feb 17 18:55:26 EST 2014

Hello. I have tried to use Forge 1.4.4 under Cygwin + Windows 8 without luck.

I'm able to execute the basic tutorial from Powershell (forge.bat). But when I try to do it from cygwin, the shell does not respond. It appears it just won't receive any command. For example:

[no project] forge $ help;
-- several minutes later, I Ctrl-C:

$ help;
GNU bash, version 4.1.11(2)-release (x86_64-unknown-cygwin)

So it appears that the commands I execute on the forge shell under cygwin just don't reach the forge shell.

I'm using also libevent2: I do use tmux under cygwin. I have tried forge with and without tmux without luck.

It would be great to me to use Forge inside cygwin. Is there something I can do for it ? Maybe yo can give me some directions?
Or maybe you can tell me some way to go to the sources and try to implement it.

Posted by forums
Original post: https://community.jboss.org/message/858151#858151

More information about the forge-users mailing list