[forge-users] Trying to run Forge under Cygwin and Windows 8 -- no command is executed

George Gastaldi ggastald at redhat.com
Mon Feb 17 19:02:17 EST 2014


Could you please give it a try with Forge 2? The shell support in Forge 1.x was not that great, that's why we changed to Aesh (aeshell.github.io).

Let us know how it goes,

George Gastaldi

> Em 17/02/2014, às 20:56, forge-users at lists.jboss.org escreveu:
> Hello. I have tried to use Forge 1.4.4 under Cygwin + Windows 8 without luck.
> I'm able to execute the basic tutorial from Powershell (forge.bat). But when I try to do it from cygwin, the shell does not respond. It appears it just won't receive any command. For example:
> [no project] forge $ help;
> -- several minutes later, I Ctrl-C:
> $ help;
> GNU bash, version 4.1.11(2)-release (x86_64-unknown-cygwin)
> ..etc
> So it appears that the commands I execute on the forge shell under cygwin just don't reach the forge shell.
> I'm using also libevent2: I do use tmux under cygwin. I have tried forge with and without tmux without luck.
> It would be great to me to use Forge inside cygwin. Is there something I can do for it ? Maybe yo can give me some directions?
> Or maybe you can tell me some way to go to the sources and try to implement it.
> Posted by forums
> Original post: https://community.jboss.org/message/858151#858151
> _______________________________________________
> forge-users mailing list
> forge-users at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/forge-users

More information about the forge-users mailing list