[forge-users] HTTP (JSON-like) API - domain mode

forge-users at lists.jboss.org forge-users at lists.jboss.org
Thu Mar 6 11:07:21 EST 2014

Strange observation. When I tried to do the same thing via the console using curl, I saw a new registry for *management realm* (in bold)
and it gave me result successfully. Once this worked, even the calls from the (firefox) poster as described above are now working fine.

curl --digest -L -D - http://user:pwd@localhost:9990/management --header "Content-Type: application/json" -d '{"operation":"read-attribute","address":[{"host":"*myhost09*"},{"server":"+server-node-A+"}],"name":"server-state"}'
HTTP/1.1 401 Unauthorized
Content-length: 0
*Www-authenticate: Digest realm="ManagementRealm",nonce="454825e7664ddd1fb62e70f4a78e3b56"*
Date: Thu, 06 Mar 2014 15:57:04 GMT

HTTP/1.1 200 OK
Transfer-encoding: chunked
Content-type: application/json
Date: Thu, 06 Mar 2014 15:57:04 GMT

{"outcome" : "success", "result" : "running"}

Posted by forums
Original post: https://community.jboss.org/message/861014#861014

More information about the forge-users mailing list