[forge-users] addon build failed (forge 2.13.0)

forge-users at lists.jboss.org forge-users at lists.jboss.org
Fri Jan 23 03:18:11 EST 2015

I tried to create an addon as described in the forge2-documentation (http://forge.jboss.org/document/develop-an-addon). 

Unfortunately the "addon-build-and-install --projectRoot forge-test" does nothing. 
- pressing enter displays a new line at the command line. 
- pressing cursor-down simple shows the prompt without any further information. 
It seems to me the command gets not executed at all. 

- pressing ctrl-4 and chosing build and install addon displays two message boxes with 
"unable to build project build" and "build failed". 
both of them are not helpful. 

Any clue how to start a command at the command line (in Eclipse Luna btw)?
Any clue how to get more detailed information when an error occured (like the set VERBOSE true in forge 1)?

The cd command is also not working anymore (it worked at 2.12.) so I am unable to change the context at the command line. 


other problems I encountered up to now (but not related to the topic of this discussion):
- When clicking at the forge console-tab I would expect to being able to directly type commands but the focus is not at the command-line. I need to perform a second click to set the focus to the command line. 
- I have no clue how to replace the old "out.println(ShellColor, String)" command. 
- How can I start a UICommand from the middle of a process
- I miss the annotations describing the necessary context (Alias, RequiresXXX, ...)

In summary: a bunch of documentation is still missing ;-)

Posted by forums
Original post: https://developer.jboss.org/message/916773#916773

More information about the forge-users mailing list