[hibernate-dev] what's going on jboss.org???

Chris Bredesen cbredesen at redhat.com
Thu Apr 23 16:59:05 EDT 2009

If you're getting the multiple last resources message, then you're not 
using XA resources.  The allowMultipleLastResources setting is a very 
dangerous thing to use and I would not recommend enabling it.

All that said, I don't understand why there'd be any long timeouts with 
all of this....


Elhanan Maayan wrote:
> thanks, i've read only half of it and i'll explain why. we had not 
> gotten to actually recovering from a transaction for simple reason that 
> we are unable to actually create one. as soon as we begin a transaction, 
> we get 2 different  jdbc data sources to oracle under a stateless 
> session ejb, when we use the 2nd getConnection jboss hangs for a half a 
> minute, and then bombs with unable to enlist data source exception. we 
> tried to walk though the debugger and it seems somethings during the 
> lock of a transaction, (we used jboss 4.2.0 which uses jbossjta 4.2.3 
> sp3 which we didn't have the source code for, so now we are trying jboss 
> 4.2.3 which uses jbossjta 4.2.3 sp7 which we do have sources for)
> before the exception occurs we see 2 warnings from arjuna i18logger 
> about multiple threads, it seems the transaction is aborting (but never 
> got to the code that actually aborted it).
> the same code worked btw on websphere 6.1
> i've seen somewhere that you could use a property called something like 
> allowMultipleResources in jbossjta.properties file , but that didn't 
> work as well.
> this reminded me of the case in jboss 3.2.5, we used spring 1.2.8 to get 
> jta transaction, but each time we actually got a transaction it 
> was already "dead" because of a time out,even though we just got it from 
> begin transaction method.
> On Thu, Apr 23, 2009 at 2:50 PM, John Mazzitelli <mazz at redhat.com 
> <mailto:mazz at redhat.com>> wrote:
>      > i'm searching for a problem we've been having about opening
>     multiple XA Data sources for oracle,
>      > (opening the second hands jboss and throws an meta-aware
>     exception, this happens in jboss 4.2)
>     This might help :-)
>     http://management-platform.blogspot.com/2008/11/transaction-recovery-in-jbossas.html
> ------------------------------------------------------------------------
> _______________________________________________
> hibernate-dev mailing list
> hibernate-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/hibernate-dev

More information about the hibernate-dev mailing list