[hibernate-dev] Unable to compile core

Juraci Paixao Krohling jcosta at redhat.com
Thu Oct 1 05:32:45 EDT 2009

Em 01-10-2009 09:54, Emmanuel Bernard escreveu:
>    From a svn update, I can't mvn clean install core/core. Anybody knows
> why?
> [INFO] Unable to resolve method [org.hibernate.Version#getVersionString]
> Embedded error: javassist.NotFoundException: org.hibernate.Version

It happens from time to time on some Hudson machines but I could not 
track it down yet. I tried, but when using the Maven's debug flag (-X, 
IIRC) the build works all the time.

If it keeps happening to you, please send me as much information as you 
can about your environment. I would love to be able to reproduce it 

To fix it, try to manually remove the "target" dir and run "mvn 
install", without the clean step. In Hudson machines, it fails again, 
but the next "mvn clean install" works fine (weird, I know, but it 
worked on two Hudson machines).

- Juca.

More information about the hibernate-dev mailing list