[hibernate-dev] Unable to compile core

Hardy Ferentschik hibernate at ferentschik.de
Thu Oct 1 05:40:24 EDT 2009

I have seen it as well, but as Juca is saying it is not re-producable.
If I just type 'mvn clean install' again it normally works. Go figure.


On Thu, 01 Oct 2009 11:32:45 +0200, Juraci Paixao Krohling  
<jcosta at redhat.com> wrote:

> Em 01-10-2009 09:54, Emmanuel Bernard escreveu:
>>    From a svn update, I can't mvn clean install core/core. Anybody knows
>> why?
>> [INFO] Unable to resolve method [org.hibernate.Version#getVersionString]
>> Embedded error: javassist.NotFoundException: org.hibernate.Version
> It happens from time to time on some Hudson machines but I could not
> track it down yet. I tried, but when using the Maven's debug flag (-X,
> IIRC) the build works all the time.
> If it keeps happening to you, please send me as much information as you
> can about your environment. I would love to be able to reproduce it
> locally.
> To fix it, try to manually remove the "target" dir and run "mvn
> install", without the clean step. In Hudson machines, it fails again,
> but the next "mvn clean install" works fine (weird, I know, but it
> worked on two Hudson machines).
> - Juca.
> _______________________________________________
> hibernate-dev mailing list
> hibernate-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/hibernate-dev

More information about the hibernate-dev mailing list