[hibernate-dev] [Search] Dynamic sharding configuration

Hardy Ferentschik hardy at hibernate.org
Tue Sep 24 08:46:43 EDT 2013

Cool, we seem to agree on almost everything now :-)

On 24 Jan 2013, at 2:30 PM, Sanne Grinovero <sanne at hibernate.org> wrote:

>> 5) rename 'getShardIdentifier' to 'getShardIdentifierForAddition'
> Is that needed? I thought that by removing the conflicting method
> there would be no further need to clarify the method. I'd propose to
> keep the method name as is, we still have the javadocs asset to
> clarify how this is all being used for the apprehensive user.

Not necessarily. Just thought it is more symmetric with getShardIdentifierForQuery.
The name implies to a certain degree where the method is used. I can go
either way on this one.


More information about the hibernate-dev mailing list