[hibernate-dev] [Search] Dynamic sharding configuration
sanne at hibernate.org
Tue Sep 24 09:16:18 EDT 2013
On 24 September 2013 13:46, Hardy Ferentschik <hardy at hibernate.org> wrote:
> Cool, we seem to agree on almost everything now :-)
+1 it's hard to get convergence when the thread explodes exponentially
on several different subjects but it seems it was worth it.
thanks for the huge energy and ideas :-)
> On 24 Jan 2013, at 2:30 PM, Sanne Grinovero <sanne at hibernate.org> wrote:
>>> 5) rename 'getShardIdentifier' to 'getShardIdentifierForAddition'
>> Is that needed? I thought that by removing the conflicting method
>> there would be no further need to clarify the method. I'd propose to
>> keep the method name as is, we still have the javadocs asset to
>> clarify how this is all being used for the apprehensive user.
> Not necessarily. Just thought it is more symmetric with getShardIdentifierForQuery.
> The name implies to a certain degree where the method is used. I can go
> either way on this one.
Let's keep the current name. I'm pretty sure we won't use it just for
additions (updates for one),
as it really is *the* method defining the relationship function
Document -> shard.
The name of getShardIdentifierForQuery is exceptional because it
really is geared for Query,
providing filtering capabilities.
> hibernate-dev mailing list
> hibernate-dev at lists.jboss.org
More information about the hibernate-dev