[hibernate-dev] Strange issue massindexer and classbridge

Marc Schipperheyn m.schipperheyn at gmail.com
Tue Mar 10 12:24:04 EDT 2015


I just wanted to share a strange issue I had w the massindexer and a
classbridge where a whole class of entities was not being indexed by the
massindexer (Hibernate Search 5.1).

The entity in question was part of an inheritance hierarchy.

Something like

I noticed that only the "Post" entities were missing from the index after
running the massindexer against BaseComment. Tried various times.

Any new entity entered would end up in the index correctly.

I finally removed a ClassBridge I use on that entity and restarted.
MassIndexer then worked correctly. And continued to work correctly after
restarts even w the classbridge active again.

I have been switching between Hibernate 4.x and 5.1 regularly and
re-indexing every time without manually cleaning the index directories.
Perhaps this had something to do with it.


More information about the hibernate-dev mailing list