[hibernate-dev] Strange issue massindexer and classbridge

Sanne Grinovero sanne at hibernate.org
Wed Mar 11 11:27:31 EDT 2015

Hi Marc,
my first guess would be that somehow the custom ClassBridge causes an
error? maybe an exception you can find in the logs?
Remember exceptions during indexing are not propagated to the
originator thread, but handled by the ErrorHandler - which by default
logs them.


On 10 March 2015 at 16:24, Marc Schipperheyn <m.schipperheyn at gmail.com> wrote:
> Hi,
> I just wanted to share a strange issue I had w the massindexer and a
> classbridge where a whole class of entities was not being indexed by the
> massindexer (Hibernate Search 5.1).
> The entity in question was part of an inheritance hierarchy.
> Something like
> BaseComment
>     Comment
>     Post
>     RSSPost
> I noticed that only the "Post" entities were missing from the index after
> running the massindexer against BaseComment. Tried various times.
> Any new entity entered would end up in the index correctly.
> I finally removed a ClassBridge I use on that entity and restarted.
> MassIndexer then worked correctly. And continued to work correctly after
> restarts even w the classbridge active again.
> I have been switching between Hibernate 4.x and 5.1 regularly and
> re-indexing every time without manually cleaning the index directories.
> Perhaps this had something to do with it.
> Cheers,
> Marc
> _______________________________________________
> hibernate-dev mailing list
> hibernate-dev at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/hibernate-dev

More information about the hibernate-dev mailing list