[jboss-user] [JBoss jBPM] - Re: Cant get jBPM to work with oracle - please help

dgutil do-not-reply at jboss.com
Thu Jul 20 03:56:41 EDT 2006

Hello sameer_pa,

I've had the same problem with the same version of the starter kit.

First, if you have a look at the build.xml in the jbpm-db folder, you will find the target called "db.scripts".

Now count the number of arguments passed to the org.jbpm.db.JbpmSchema java class. In my case there 5 arguments passed to it.

   <target name="db.scripts" description="helper target to generate the database scripts" depends="prepare">
  |   	<delete dir="build/${db}/scripts" />
  |     <mkdir dir="build/${db}/scripts" />
  |     <java classname="org.jbpm.db.JbpmSchema" fork="true">
  |       <classpath refid="classpath.${db}" />
  |       <arg value="scripts"/> 
  |       <arg value="${basedir}/build/${db}/scripts"/> 
  |       <arg value="${db}"/> 
  |       <arg value="${jbpm.3.location}/src/config.files/hibernate.cfg.xml"/> 
  |       <arg value="${basedir}/${db}/hibernate.properties"/> 
  |     </java> 
  |   </target>

Second, open the org.jbpm.db.JbpmSchema java class in the jbpm\src\java.jbpm\org\jbpm\db folder and please have a look at the main method. You notice that it only deals with 1 or 3 arguments whereas the build.xml file passes 5 arguments to it.

I simply added this test in the main method:

else if ( (args!=null)
  | 	          && (args.length>3)
  | 	          && ("scripts".equalsIgnoreCase(args[0])) ) {
  |         new JbpmSchema(JbpmSessionFactory.createConfiguration()).saveSqlScripts(args[1], args[2]);
  |       }

Then I ran "ant mysql.scripts" and it worked.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=3959461#3959461

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=3959461

More information about the jboss-user mailing list