[jboss-user] [Tomcat, HTTPD, Servlets & JSP] - Re: Unwaring web app - leaves some files in the war

PeterJ do-not-reply at jboss.com
Thu Dec 20 13:02:14 EST 2007

Wow, lots of posts. Let me see what I can answer.

First, I did see where you stated that in 4.2.x that the work directory does not contain web-inf, but as I pointed out you never said that the app worked correctly there, though you did now.  The presence of the web-inf directory under the work directory does not necessarily indicate a problem -  the class loader could still load the classes from the web-inf/lib directory in the exploded directories, in which case the code could work even though the web-inf/lib and its jars are in the work directory.

I have added a conf/config.properties to my war. And I tried the exploded ear with the exploded war in 4.2.x, 5.0 beta2 and a early version on beta3. And I tried it on Linux and XP. The results?

         4.2.x     beta2     beta3
  |          _____     _____     _____
  | XP       works     broke     broke
  | Linux    works     works     works

It is somewhat interesting that the deployer is not working correctly on Windows. Just for grins, I tried beta3 on Vista, it's broke there too.

As I mentioned earlier, deployment in beta2 is broken in so many ways. Congratulations on finding yet another way that it is broken. And the issue with redeployment not happing when you touch application.xml is yet another way deployment is broken in beta2. But hey, hot deployment was not working at all in beta1. You should try the touching application.xml thing in beta3 when it comes out (I'm guessing next week).

One final bit of info: in 5.0, the hot deployment configuration is found in the file server/xxx/conf/bootstrap-beans.xml, look for a bean named HDScanner. In addition, there are several other beans that aid in deployment.

So what should you do about your problem. I suggest that either:

a) you deploy in Linux
b) you fall back to 4.2.x

The behavior of the deployer on Windows in the 5.0 betas is clearly wrong, not sure if there is a JIRA issue for that problem (anyone from RedHat want to chime in on that?).

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4114741#4114741

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4114741

More information about the jboss-user mailing list