[jboss-user] [JBossWS] - problem with jbossws examples

b_ do-not-reply at jboss.com
Mon Dec 31 09:10:38 EST 2007

Hi all, 

I was able to get the jaxrpc-rpc style sample that is shipped with the jbossws 1.0.4.GA up and running. After running the build script in the samples root folder , i grabbed the .jar and .war generated in the samples/output/libs and dropped them into the jboss deploy folder. I also managed to write my own client application that consumes the web service.

I then tried to build the example from scratch myself. I modified and arranged the build.xml file (samples\jaxrpc\rpcstyle\build.xml) for my project. However when running the build file i am getting the following error:

  |  generate-sources:
  |      [echo] Started target generate-sources
  |   [wstools] org.jboss.ws.WSException: Endpoint com.thesis.ws.TrivialService cannot be loaded
  |   [wstools]     at org.jboss.ws.tools.helpers.ToolsHelper.handleJavaToWSDLGeneration(ToolsHelper.java:113)
  |   [wstools]     at org.jboss.ws.tools.WSTools.process(WSTools.java:129)
  |   [wstools]     at org.jboss.ws.tools.WSTools.generate(WSTools.java:119)
  |   [wstools]     at org.jboss.ws.tools.ant.wstools.execute(wstools.java:103)
  |   [wstools]     at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
  |   [wstools]     at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
  |   [wstools]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
  |   [wstools]     at java.lang.reflect.Method.invoke(Method.java:585)
  |   [wstools]     at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
  |   [wstools]     at org.apache.tools.ant.Task.perform(Task.java:348)
  |   [wstools]     at org.apache.tools.ant.Target.execute(Target.java:357)
  |   [wstools]     at org.apache.tools.ant.Target.performTasks(Target.java:385)
  |   [wstools]     at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
  |   [wstools]     at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
  |   [wstools]     at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
  |   [wstools]     at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
  |   [wstools]     at org.apache.tools.ant.Main.runBuild(Main.java:698)
  |   [wstools]     at org.apache.tools.ant.Main.startAnt(Main.java:199)
  |   [wstools]     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
  |   [wstools]     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

I also tried adding TrivialService.class to the classpath ... but to no avail.

Any help would be appreciated at this point!

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4116173#4116173

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4116173

More information about the jboss-user mailing list